给Drupal安装后台搜索服务xunsearch

大伟哥 提交于 2020-07-04,周六, 11:47 ,最近更新于2020-07-04,周六, 15:59

大伟哥最近准备使用Drupal的facets模块给上网站上的商品列表页面加上筛选选项,实现类似京东和淘宝那样根据产品参数属性来筛选产品的功能,这样可以极大地提高用户体验。而这个功能则需要facets模块、Search API模块结合一个后端的搜索服务来实现。在Drupal群里经过龙马大佬推荐,我最终选择了对中文支持比较好的迅搜(xunsearch)。

在按官方文档安装xunserch服务的过程中碰到了报错:

标签

使用Composer接管以前手动安装的Drupal网站

大伟哥 提交于 2020-07-03,周五, 17:08 ,最近更新于2020-07-03,周五, 17:08

Drupal越来越倾向于使用Composer来管理代码库了,好多模块不使用Composer都不容易安装成功。那对于以前下载上传又手动安装配置的Drupal网站,怎么样才能搭上Composer的快车呢?大伟哥经过对Drupal文档的学习和实际测试,发现很容易就可以免票上车了。上了车之后再回头看,才知道阻碍我们拥抱Composer的,不是Composer真的复杂难学,而是习惯的力量和对未知事物的恐惧。我们要始终意识到这样一个事实:Composer是来帮我们的,不是来制造麻烦的。

使用Composer给Drupal打Patch补丁

大伟哥 提交于 2020-06-23,周二, 10:58 ,最近更新于2020-06-23,周二, 16:26

使用Composer可以方便地管理Drupal核心版本和模块版本的更新,那如果是已经有Drupal的补丁解决了你急需要解决的问题,而Drupal核心团队或者模块作者还没来得及或者压根不想把补丁打包进新的版本呢?使用Composer追求自动化的你一定不想在Composer每次更新版本之后,还要再次手动给Drupal打补丁。既然用了Composer,那就让Composer全部代劳吧,连补丁一块儿。

要想让Composer干好这活, 得给它额外安装个工具,叫composer-patches。安装很简单,在项目根目录里require一下就行了:

标签

Composer:Cloning failed using an ssh key for authentication, enter your GitHub credentials to access private repos

大伟哥 提交于 2020-06-22,周一, 22:42 ,最近更新于2020-06-23,周二, 09:53

Composer真香,使用composer是会上瘾的,大伟哥已经决定把所有的Drupal网站都使用Composer来接管了。不过最近在阿里云ECS上使用Composer来安装依赖的时候,遇到了这样的错误:

解决PHP7.3下Magento1.9.4管理后台显示空白页面的问题

大伟哥 提交于 2020-05-28,周四, 09:18 ,最近更新于2020-05-28,周四, 09:44

Magento 1.9.4版本的官方发布说明上,是支持到PHP7.2版本的。大伟哥换了新的阿里云服务器以后,安装的是PHP7.3,当时也有些担心会不会不兼容,但是迁移过来以后,发现各个页面都能正常打开,也就放着不管了。

直到今天,想进Magento后台去修改某项配置,却发现输入管理员用户名和密码之后,页面跳转不正常,打开的页面是空白页,不能正常显示后台内容。这吓了我一跳,难不成真是PHP版本不兼容的问题?

Apache的错误日志显示如下:

标签